aboutsummaryrefslogtreecommitdiffstats
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
authorjustanothercatgirl <sotov@twistea.su>2025-02-08 22:13:52 +0300
committerjustanothercatgirl <sotov@twistea.su>2025-02-08 22:13:52 +0300
commitcab382db088d9f240253466a1c5a26c62f3967c8 (patch)
treec5502f1b49211dccd3e29e163e708708495a6407 /server/CMakeLists.txt
parent3eeee14d5d5c93ae3d156aabae5a96d1c09f185a (diff)
Implemented multiplexing in main thread (TCP loop). Removed CMake files.HEADmaster
TODO: Implement multiplexing in worker threads (UDP loops), implement channel_pool interface.
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
deleted file mode 100644
index f63f897..0000000
--- a/server/CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-# CMake files will be removed in the next several commits
-
-cmake_minimum_required(VERSION 3.20)
-
-project(kv_server
- VERSION 0.0
- DESCRIPTION "A server for kv project."
- LANGUAGES C)
-
-set(SOURCE_FILES main.c channel.c tcp.c ../include/packet.c)
-set(HEADER_FILES channel.h tcp.h)
-
-add_executable(kv_server ${SOURCE_FILES})
-target_compile_definitions(kv_server PUBLIC DEBUG)
-target_link_libraries(kv_server
- PUBLIC crypto
- PUBLIC pthread
-)
-
-
-