aboutsummaryrefslogtreecommitdiffstats
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
deleted file mode 100644
index f63f897..0000000
--- a/server/CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-# CMake files will be removed in the next several commits
-
-cmake_minimum_required(VERSION 3.20)
-
-project(kv_server
- VERSION 0.0
- DESCRIPTION "A server for kv project."
- LANGUAGES C)
-
-set(SOURCE_FILES main.c channel.c tcp.c ../include/packet.c)
-set(HEADER_FILES channel.h tcp.h)
-
-add_executable(kv_server ${SOURCE_FILES})
-target_compile_definitions(kv_server PUBLIC DEBUG)
-target_link_libraries(kv_server
- PUBLIC crypto
- PUBLIC pthread
-)
-
-
-