aboutsummaryrefslogtreecommitdiffstats
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
authorjustanothercatgirl <sotov2070@gmail.com>2024-07-04 20:49:53 +0300
committerjustanothercatgirl <sotov@twistea.su>2025-02-02 19:09:51 +0300
commit3eeee14d5d5c93ae3d156aabae5a96d1c09f185a (patch)
treef23794a428cf663498cff01a148a3f398d42f120 /server/CMakeLists.txt
parent0cd383b2c444936dc2290c850c02a0cae11187cd (diff)
Renamed types, migrated to make, changed directory hierarchy
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
index 0ba4d8b..f63f897 100644
--- a/server/CMakeLists.txt
+++ b/server/CMakeLists.txt
@@ -1,3 +1,5 @@
+# CMake files will be removed in the next several commits
+
cmake_minimum_required(VERSION 3.20)
project(kv_server
@@ -5,10 +7,15 @@ project(kv_server
DESCRIPTION "A server for kv project."
LANGUAGES C)
-set(SOURCE_FILES main.c channel.c)
-set(HEADER_FILES channel.h)
+set(SOURCE_FILES main.c channel.c tcp.c ../include/packet.c)
+set(HEADER_FILES channel.h tcp.h)
add_executable(kv_server ${SOURCE_FILES})
target_compile_definitions(kv_server PUBLIC DEBUG)
+target_link_libraries(kv_server
+ PUBLIC crypto
+ PUBLIC pthread
+)
+