aboutsummaryrefslogtreecommitdiffstats
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
new file mode 100644
index 0000000..0ba4d8b
--- /dev/null
+++ b/server/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.20)
+
+project(kv_server
+ VERSION 0.0
+ DESCRIPTION "A server for kv project."
+ LANGUAGES C)
+
+set(SOURCE_FILES main.c channel.c)
+set(HEADER_FILES channel.h)
+
+add_executable(kv_server ${SOURCE_FILES})
+target_compile_definitions(kv_server PUBLIC DEBUG)
+
+