aboutsummaryrefslogtreecommitdiffstats
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
authorjustanothercatgirl <sotov2070@gmail.com>2024-06-21 18:49:43 +0300
committerjustanothercatgirl <sotov2070@gmail.com>2024-06-21 18:55:09 +0300
commitb0af12b287a7c7e3cc5ba39869835126e700f792 (patch)
tree5cc3e225fc4022e4a5a99d5a3c318396f183398d /server/CMakeLists.txt
initial commit
TODO: implement O_NONBLOCK switching on channel socket
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
new file mode 100644
index 0000000..0ba4d8b
--- /dev/null
+++ b/server/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.20)
+
+project(kv_server
+ VERSION 0.0
+ DESCRIPTION "A server for kv project."
+ LANGUAGES C)
+
+set(SOURCE_FILES main.c channel.c)
+set(HEADER_FILES channel.h)
+
+add_executable(kv_server ${SOURCE_FILES})
+target_compile_definitions(kv_server PUBLIC DEBUG)
+
+