aboutsummaryrefslogtreecommitdiffstats
path: root/server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'server/CMakeLists.txt')
-rw-r--r--server/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
index 0ba4d8b..f63f897 100644
--- a/server/CMakeLists.txt
+++ b/server/CMakeLists.txt
@@ -1,3 +1,5 @@
+# CMake files will be removed in the next several commits
+
cmake_minimum_required(VERSION 3.20)
project(kv_server
@@ -5,10 +7,15 @@ project(kv_server
DESCRIPTION "A server for kv project."
LANGUAGES C)
-set(SOURCE_FILES main.c channel.c)
-set(HEADER_FILES channel.h)
+set(SOURCE_FILES main.c channel.c tcp.c ../include/packet.c)
+set(HEADER_FILES channel.h tcp.h)
add_executable(kv_server ${SOURCE_FILES})
target_compile_definitions(kv_server PUBLIC DEBUG)
+target_link_libraries(kv_server
+ PUBLIC crypto
+ PUBLIC pthread
+)
+