aboutsummaryrefslogtreecommitdiffstats
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
new file mode 100644
index 0000000..116ef40
--- /dev/null
+++ b/client/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.20)
+
+project(kv_client
+ VERSION 0.0
+ DESCRIPTION "I will work on this one later"
+ LANGUAGES C)
+
+set(SOURCE_FILES main.c ../server/channel.c)
+set(HEADER_FILES ../server/channel.h)
+
+add_executable(kv_client ${SOURCE_FILES})
+target_link_libraries(kv_client PRIVATE opus c)