aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..8c4e95b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.20)
+
+project(kv
+ VERSION 0.0
+ DESCRIPTION "Just see the readme file in this repo"
+ LANGUAGES C)
+
+set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
+include_directories(include include/c_headers/include)
+
+add_compile_options(-Wall -Wextra -Wpedantic -Werror -g)
+
+add_subdirectory(server)
+add_subdirectory(client)