aboutsummaryrefslogtreecommitdiffstats
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorjustanothercatgirl <sotov2070@gmail.com>2024-07-04 20:49:53 +0300
committerjustanothercatgirl <sotov@twistea.su>2025-02-02 19:09:51 +0300
commit3eeee14d5d5c93ae3d156aabae5a96d1c09f185a (patch)
treef23794a428cf663498cff01a148a3f398d42f120 /client/CMakeLists.txt
parent0cd383b2c444936dc2290c850c02a0cae11187cd (diff)
Renamed types, migrated to make, changed directory hierarchy
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 116ef40..266ddf1 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -1,3 +1,5 @@
+# CMake files will be removed in the next several commits
+
cmake_minimum_required(VERSION 3.20)
project(kv_client
@@ -5,8 +7,9 @@ project(kv_client
DESCRIPTION "I will work on this one later"
LANGUAGES C)
-set(SOURCE_FILES main.c ../server/channel.c)
-set(HEADER_FILES ../server/channel.h)
+set(SOURCE_FILES main.c ../include/packet.c)
+set(HEADER_FILES ../include/packet.h)
add_executable(kv_client ${SOURCE_FILES})
+target_compile_definitions(kv_client PUBLIC DEBUG)
target_link_libraries(kv_client PRIVATE opus c)