aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index a7d9c5a..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-# CMake files will be removed in the next several commits
-
-cmake_minimum_required(VERSION 3.20)
-
-project(kv
- VERSION 0.0
- DESCRIPTION "Just see the readme file in this repo"
- LANGUAGES C)
-
-set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
-include_directories(include include/c_headers/include)
-
-add_compile_options(-Wall -Wextra -Wpedantic -Werror -g)
-
-add_subdirectory(server)
-add_subdirectory(client)